Android 5.0之前的Camera API在5.0之后的设备上还适用吗

Android 5.0之后推荐使用新的Camera2 API, 那么5.0之前的Camera API写的Camera应用在5.0之后的设备上还能够跑吗? 5.0 API里面对以前的Camera API写的是弃用,我想知道这里“弃用”的意思是不推荐用还是不能用? 因为app要兼容4.0到5.0,不能搞两套吧。

标记 deprecatedAPI ,表示是当前版本中还能够正常使用,而将要在之后的版本中祛除,所以在这个过程中,给开发者留出时间做出相应的程序修改。

兼容的方法也很简单,就是 搞两套 ,在程序中根据不同的 API 版本,使用不同的接口。 Android Support Library 就是这样去适配不同版本的 API

楼上正解,搞两套不是说app做两个版本,而是类似support library那样处理,相同的接口可以自行封装一个统一的调用接口,实现中根据不同的os版本调用不同版本的api来完成功能,比如:

class XXXCompat { ... fun funcA { if Build.VERSION.SDK_INT >= 21 { // call new apiwrapper } else { // call old apiwrapper } } ...
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注